Fixed [4.0b1 BUG] ROM filtering issues

Bugs are now stored in a bug tracker application. Click on the "Support/Bug reports" link above.

Moderator: Wanderer

User avatar
Board master
Board master
Posts: 789
Joined: Wed Oct 03, 2001 10:37 am
Location: Milky way

Fixed [4.0b1 BUG] ROM filtering issues

Post by Wanderer »

It seems that the filter that exists in the top of the ROMs tab is not working so well.

1. It's case sensitive. IMO it shouldn't.

2. For some reason, it seems that if you enter one letter, it does nothing but if you enter a second one, then it starts working but not always.
For instance, i tried filtering a rom folder i added in an Amstrad CPC db ("Amstrad CPC - Applications - [BIN]" from the respective new TOSEC collection).
- I entered "cp" and on "p" it started working.
- I entered "CP" but i also needed to type an "M" in order for the list to be filtered.
- I entered "DD" and the filtering worked!

3. When you filter a ROM folder, then click somewhere else (i.e. on a DB branch) and then return to the ROM folder, it seems that RC remembers the filter you had previously entered (nice touch here Eric!), however it would be better if that string also appeared in the "Filter" field again. Now it's just blank but with the filter working, it's confusing. It would also be nice to have a visual way to clear the filter (i.e. a button with a red X circle at the left/right of the filter field).