Help! Issue when trimming rom sets to 1G1R

Romcenter 4 support discussion. Please do not post roms requests or illegal links, posts will be deleted.

Moderators: Wanderer, Logiqx, Iron Man

Forum rules
No roms requests or illegal links
hoodwill
Pong
Pong
Posts: 1
Joined: Mon Jan 21, 2019 2:46 am

Help! Issue when trimming rom sets to 1G1R

Post by hoodwill » Mon Jan 21, 2019 9:58 pm

Hello Eric -- thank you for making awesome software! It is greatly appreciated. :)

I am using RomCenter 4.0.0.rc3 to trim my romsets to 1G1R. Results are mostly good, but when I fix my collection some games remain unknown. I will illustrate with Mortal Kombat for snes.

My issue:
When cleaning my snes roms dir (which contains GoodSet, No-Intro, and various other versions found online), any and all versions of Mortal Kombat remain unknown when compared to the database, and I am left with no copies of the game when I run the ‘fix’/’clean’ process. I have versions of this rom from my region (USA), and their checksums match, but because I do not have the latest trusted copy from the .dat file, RC removes all copies. Should it not default to the previous trusted dump for my region instead? Or maybe retain the parent, or a clone from the same parent that matches my region? I am still new so I am unsure if these are settings options.

Collection shows a USA version, and the parent:
rompost02.PNG
rompost02.PNG (22.5 KiB) Viewed 1889 times
1G1R does not keep one from USA:
rompost01.PNG
rompost01.PNG (32.79 KiB) Viewed 1889 times
My process:
Load .dat or .xml file
Select region order and create db
Point to snes roms dir
Fix

Tools tried:
RomCenter 4.0.0.rc3
RomCenter 3.7.1.0

Region order:
Us / Ca / Au / Eu / Jp / As / Kr / Cn

DATs tried:
Datomatic: Nintendo - Super Nintendo Entertainment System (Combined) (Parent-Clone) (20190118-132306).dat
Datomatic: Nintendo - Super Nintendo Entertainment System (Combined) (20190118-132306).dat

Rom extensions:
.smc / .sfc / .zip / .7z

User avatar
RomCenter
Author
Author
Posts: 1375
Joined: Fri Sep 28, 2001 12:34 pm
Location: France
Contact:

Re: Help! Issue when trimming rom sets to 1G1R

Post by RomCenter » Sun Jan 27, 2019 6:52 pm

Hi
This is the normal behaviour. 1G1R filter occurs on datafile, not on files.
I set up a wiki page to explain the concept.
Eric - RomCenter developer
http://www.romcenter.com

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests